端末エミュレータ・EDIソリューション・FAX/CTIソリューション・Webメール・Web会議 各種製品のサポート情報を公開しています

キヤノンITソリューションズ パッケージプロダクトサポート

ホーム - バージョン情報 - EDI-Master DEX Business Server (Ver.1.01-05 -> Ver.1.02-02)

バージョン情報

EDI-Master DEX Business Server
(Ver.1.01-05 -> Ver.1.02-02)
 
強化項目
[サーバ機能関連]
○1つのフォルダに対して、複数の通信定義を割り当てられるようにしました。

[コマンド実行機能関連]
○フォルダ転送単位に以下のコマンドを指定できるようにしました。
 転送前に実行するコマンド
 正常終了時に実行するコマンド
 異常終了時に実行するコマンド

[セキュリティ関連]
○128ビットSSL通信(SGC証明書)に対応しました。
改修項目
以下の問題点を改修しました。

[システム全般]
○運用中にCPU使用率が100%になる場合がある。

[サーバ機能関連]
○通信環境やフォルダを新規に登録する場合、設定を保存する際に入力エラーが検出されると、入力情報がすべて破棄される。

○フォルダに追加したファイルに、MIME管理で設定したMIMEタイプが反映されない。

○他のアプリケーションが使用しているポート番号を設定しても、サーバが起動してしまう。

○データ転送中に転送状況の参照や他のデータ転送の開始ができない。

○定義情報が正しく保存されない場合がある。

○WebサーバにInternet Information Servicesを使用すると、クライアントがダウンロードできない。

○フォルダ名にダブルクォーテーションや「¥」を含むフォルダに関連づけた通信定義の設定画面を表示すると、ランタイムエラーが発生する。

[ファイル転送機能関連]
○Windows 2000上では、フォルダにサイズの大きいファイルを登録するのに時間がかかる。

○フォルダ転送中にマシンの再起動を行うと、「処理中」のステータスが残り、次回からフォルダ転送ができなくなる場合がある。

○ファイル転送後に非同期でコマンドを呼び出す場合、同時に複数のクライアントからファイル転送を実行すると、サーバがフリーズすることがある。

○バイナリからBASE64への変換が正しく行われないことがある。

○BASE64からバイナリへの変換で、変換後のデータ長が実際のデータより大きくなることがある。

○1次局で定義されていない通信定義に対して、2次局から送信しても送信処理が成功してしまう。

○全銀HTTPプロトコルでプロキシサーバ経由の接続ができないことがある。

○サーバでの受信中に通信タイムアウトが発生すると、次に正常受信した時、受信フォルダ内に障害ファイルが残る。

○1次局に登録された0バイトのデータファイルを2次局で受信するとエラーとなる。

○0バイトのデータファイルを抽出できない。

[コマンド実行機能関連]
○デフォルトのインストールフォルダ以外でクライアントをセットアップすると、シェル実行が失敗する。

[スケジュール機能関連]
○スケジュール一覧で、実行中のスケジュールの「次回実行予定日時」に“コマンド実行中”と表示されないことがある。

○1つのコマンドに対して複数の期日指定を含むスケジュールを設定した場合、1つのスケジュールの期限を越えるとすべてのスケジュールが実行されなくなる。

○毎日コマンドを実行するようにスケジュールを設定しても、設定当日しかスケジュールが起動しない。

[運用管理機能関連]
○コマンド実行で戻り値の扱いを[常に正常扱い]に設定しても、正常終了とならないことがある。

○DEXマネージャで、システムの起動時にサーバを起動しないように設定しても、保存されない。

○シェル実行コマンドのパラメータに、ダブルクォーテーションを含んだコマンドラインを設定しても、ダブルクォーテーションが保存されない。

○Administrators権限でないユーザでWindowsにログオンすると、DEXマネージャの機能が使用できない。

[クライアント機能関連]
○クライアント環境で、[状況表示]メニューに[ログインユーザ一覧]サブメニューが表示されない。

○クライアントをサービスで自動起動するように設定すると、クライアントOSがWindows 9X系の場合、起動時にエラーが発生する。

[インストール/アンインストール関連]
○DEX Business Serverを起動したままアンインストールすると、いくつかのファイルが削除されずに残ることがある。

[API機能関連]
○コマンドラインユーティリティのCATALOGで、/TYPEオプションに“LINK”を指定しても、「指定されたファイルが見つからない」旨のエラーが発生する。